You are not logged in. Click here to log in.

codeBeamer Application Lifecycle Management (ALM)

Search In Project

Search inClear

Tags:  not added yet
codeBeamer 20.11-LTS (Carmen) - General information
  • Every customer should renew their codeBeamer 20.11-LTS Licenses before upgrading, please contact with your Sales representative using sales@intland.com email address
  • Please note that Upgrading to Carmen version can take several hours. It is highly recommended to execute during Weekend
  • Oracle 12 is no longer supported please update to the officially supported Oracle 19 version
  • Internet Explorer 11 is no longer supported, please user Supported Browsers instead.
  • Microsoft Office support starting from Microsoft Office 2013, older versions are no longer supported.
  • Derby Database is no longer supported
  • Read more about Swagger API changes using the following Article

System Requirements

This page describes the hardware and software requirements of codeBeamer 20.11. For general requirements, please refer to the wiki page titled System Requirements.

Operating Systems

Windows and Linux on 64-bit x86 architectures with at least 8 GB memory. 32-bit operating systems are no longer supported.

The amount of memory required depends on the number of concurrent users, and the data in the system.

Virtual Systems

codeBeamer 20.11 versions are tested with VMware ESX 6.5.0, ESX 6.7.0, Amazon Elastic Compute Cloud (Amazon EC2) and Azure virtual machines

Docker

Docker image is changed, please note the following changes

  • centos:8.1.1911 is used as a base image
  • additional environment variables are added
  • hosted SCMs are removed from the image
  • codeBeamer is available on http://localhost/ without /cb

Docker image is tested with 18.06.1-ce version of Docker

Docker with OpenShift

Docker and OpenShift configurations are automatic, please follow the installation instructions.

Supported Java Runtime Environment (JRE)

Platform Version Tested with Recommended Platform
Open JDK 1.8.0.262 or higher 1.8.0_262-b10 / 64-Bit ALT_WIKI:EMOTICON:%28%2F%29%20 Windows
Open JDK 1.8.0.262 or higher 1.8.0_262-b10 / 64-Bit ALT_WIKI:EMOTICON:%28%2F%29%20 Linux

Supported Application Servers

codeBeamer is shipped and tested with Apache Tomcat 8.5.58. The windows-based installer has the tomcat application server already included.

It is recommended to upgrade to Apache Tomcat 8.5.58 version because of http://tomcat.apache.org/security-8.html.

codeBeamer 20.11-LTS Supported Databases

Database Version Tested with Recommended
MySQL 5.7 5.7.24, 5.7.26 ALT_WIKI:EMOTICON:%28%2F%29%20
Oracle Oracle 19.x Enterprise Edition 19.3c ALT_WIKI:EMOTICON:%28%2F%29%20
MySQL 8.0
All automatised tests are successful with MySQL 8, however regression tests were executed only with MySQL 5.7.
8.0.21 ALT_WIKI:EMOTICON:%28-%29%20
Oracle Oracle 12.2.x Enterprise Edition,
All regression tests, Functional tests and Performance tests were executed only with Oracle 19.3c
12.2.0.1.0 ALT_WIKI:EMOTICON:%28-%29%20
PostgreSQL 11.8
All automatised tests are successful with PostgreSQL 11.8, however regression tests were not executed and not functional tested.
11.8 ALT_WIKI:EMOTICON:%28-%29%20

codeBeamer 20.11-LTS Supported Browsers

In all browsers, JavaScript must be enabled to use the full functionality of codeBeamer.

Browser Version Tested with
Microsoft Edge 86.0.x 86.0.622.51
Firefox 82.0.x 82.0
Chrome 86.0.x 86.0.4240.111

Source Code Management Systems (SCM)

Git 2.11 or higher tested with Git 2.11, 2.18.2
Subversion 1.7.x, 1.8.x, 1.9.x tested with 1.8.8, 1.9.1
Mercurial
(requires special support contract)
3.0.1 or higher tested with 3.7.3
Perforce
(requires special support contract)
7.0 or higher tested with 7.0.16.1930

JIRA Integration

JIRA Server version Tested with
JIRA 7.2.6 or higher JIRA 7.2.6 and 7.5.1.

Microsoft Office

Windows 10
Office 2016 Edge
Chrome (latest)
Firefox (latest)
Office 365 Edge
Chrome (latest)
Firefox (latest)
Mac OS X Office 2016 Chrome (latest)
Firefox (latest)

You can find more details about Office Edit support

Limitation

  • Work Item exporting on Table Views always considering Outline ordering as was introduced in codeBeamer 10.1.x release. It is planned to improve in close future.
Office edit / Webdav have problems with Mac Office 2016 does not work with Office edit.